fvwm CDE風 CentOS

http://fvwm-themes.sourceforge.net/rpm/
# rpm -ivh fvwm-2.5.27-1.i386.rpm fvwm-themes-0.7.0-2.noarch.rpm wm-icons-0.4.0-1.noarch.rpm
エラー: 依存性の欠如:
libfribidi.so.0 は fvwm-2.5.27-1.i386 に必要とされています
libgdk-1.2.so.0 は fvwm-2.5.27-1.i386 に必要とされています
libglib-1.2.so.0 は fvwm-2.5.27-1.i386 に必要とされています
libgmodule-1.2.so.0 は fvwm-2.5.27-1.i386 に必要とされています
libgtk-1.2.so.0 は fvwm-2.5.27-1.i386 に必要とされています
libstroke.so.0 は fvwm-2.5.27-1.i386 に必要とされています
# yum install libglib-1.2.so.0
# yum install libfribidi.so.0
# yum install libgdk-1.2.so.0
# yum install libgmodule-1.2.so.0 libgtk-1.2.so.0 libstroke.so.0
Package 1:glib-1.2.10-20.el5.i386 already installed and latest version
Package 1:gtk+-1.2.10-56.el5.i386 already installed and latest version
No package libstroke.so.0 available.

http://www.rpmfind.net/linux/rpm2html/search.php?query=libstroke.so.0

libstroke-0.5.1-21.el5.i386.htmlA stroke interface libraryEPEL 5 for i386libstroke-0.5.1-21.el5.i386.rpm

# rpm -ivh libstroke-0.5.1-21.el5.i386.rpm
# rpm -ivh fvwm-2.5.27-1.i386.rpm fvwm-themes-0.7.0-2.noarch.rpm wm-icons-0.4.0-1.noarch.rpm
準備中... ########################################### [100%]
1:fvwm ########################################### [ 33%]
2:fvwm-themes ########################################### [ 67%]

If you are running fvwm-themes now, to avoid problems choose
'Reset all to the default' from the Theme Management menu.

3:wm-icons ########################################### [100%]

# switchdesk fvwm

# touch /usr/share/xsessions/fvwm.desktop
# vi /usr/share/xsessions/fvwm.desktop
[Desktop Entry]
Encoding=UTF-8
Name[ja]=fvmw
Comment=
Exec=fvmw
Icon=
TYpe=Application


~/.fvwm/.fvwm2rcを開いて、以下を追記します。

AddToMenu MenuFvwmQuitVerify "$[gt.Really Quit Fvwm?]" Title
+ "&Q. $[gt.Yes, Really Quit]" Quit
+ "" Nop
+ "&R. $[gt.Restart]" Restart
+ "" Nop
+ "&F. $[gt.Start] fvwm-themes" Restart fvwm-themes-start
+ "&T. $[gt.Start] twm" Restart twm

下準備はこれだけ。
Fvwmでログインしてテーマ変更。ヽ(´ー`)ノ
a0021920_1643726.gif

[PR]
by tenten909 | 2011-04-16 16:43 | PC-Unix等