libgstlame.so

SUSE LinuxマシンのBanshee(iTUNESみたいなソフト)でMP3にエンコードするために、codecs-gnome.ympをopensuse-community.orgからインストール。
だけど、エンコードにMP3は選べない。
まずは自分のhomeディレクトリ以下の.config/bansheeを疑ったけど、それらしき記述は見当たらない。次に /usr/lib/bansheeをみまわしたけどサッパリ。/usr/share/banshee/audio-profilesを見ると、ちゃんと mp3-lame.xmlという設定ファイルもある。

lameだけzypperでインストールするも変化なし・・・

諦めかけてたんだけど、ubuntu Linux の入ってるマシンにbansheeをインストール。するとちゃんとMP3エンコーダーがある。むむむ。ちょー悔しくなってきた。

この手のマルチメディア系アプリはGStreamerなるものが関係してるらしいって事をどこか読んだのを思いだし、GStreamerのディレクトリをさがしました。
/usr/lib/gstreamer-0.10
ubuntuとSUSEの両方のディレクトリを見比べててついに発見。libgstlame.so

#zypper install libgstlame.so
としたら、そんなのネーよと言われたので
無茶は承知でubuntuのlibgstlame.soをSUSEにコピー!!!

banshee起動!

するとちゃんとMP3変換が選択できる!!!

むぅ、3時間も費やしてしまった(涙

追記:
http://rpmfind.net/linux/rpm2html/search.php?query=gstreamer-lame
http://rpm.pbone.net/index.php3/stat/4/idpl/6390814/com/gstreamer0.10-lame-0.10.7-4plf2008.1.i586.rpm.html
↑にlibgstlame.soのRPMパッケージが落ちてました。

またlameもインストールしておかないと有効にならないです。
[PR]
by tenten909 | 2008-03-20 17:57 | PC-Unix等