# yum install expect

10文字のパスワードを生成する場合。
# mkpasswd -l 10

[主なオプション]
-l 生成されるパスワードの文字数
-d パスワード中に含まれる数字の最低文字数を指定
-c パスワード中に含まれる小文字の最低文字数を指定
-C パスワード中に含まれる大文字の最低文字数を指定
-s パスワード中に含まれる特殊文字の最低文字数を指定

参照ページ
インストール
コマンド説明
[PR]
by tenten909 | 2011-04-21 15:56 | PC-Unix等
http://fvwm-themes.sourceforge.net/rpm/
# rpm -ivh fvwm-2.5.27-1.i386.rpm fvwm-themes-0.7.0-2.noarch.rpm wm-icons-0.4.0-1.noarch.rpm
エラー: 依存性の欠如:
libfribidi.so.0 は fvwm-2.5.27-1.i386 に必要とされています
libgdk-1.2.so.0 は fvwm-2.5.27-1.i386 に必要とされています
libglib-1.2.so.0 は fvwm-2.5.27-1.i386 に必要とされています
libgmodule-1.2.so.0 は fvwm-2.5.27-1.i386 に必要とされています
libgtk-1.2.so.0 は fvwm-2.5.27-1.i386 に必要とされています
libstroke.so.0 は fvwm-2.5.27-1.i386 に必要とされています
# yum install libglib-1.2.so.0
# yum install libfribidi.so.0
# yum install libgdk-1.2.so.0
# yum install libgmodule-1.2.so.0 libgtk-1.2.so.0 libstroke.so.0
Package 1:glib-1.2.10-20.el5.i386 already installed and latest version
Package 1:gtk+-1.2.10-56.el5.i386 already installed and latest version
No package libstroke.so.0 available.

http://www.rpmfind.net/linux/rpm2html/search.php?query=libstroke.so.0

libstroke-0.5.1-21.el5.i386.htmlA stroke interface libraryEPEL 5 for i386libstroke-0.5.1-21.el5.i386.rpm

# rpm -ivh libstroke-0.5.1-21.el5.i386.rpm
# rpm -ivh fvwm-2.5.27-1.i386.rpm fvwm-themes-0.7.0-2.noarch.rpm wm-icons-0.4.0-1.noarch.rpm
準備中... ########################################### [100%]
1:fvwm ########################################### [ 33%]
2:fvwm-themes ########################################### [ 67%]

If you are running fvwm-themes now, to avoid problems choose
'Reset all to the default' from the Theme Management menu.

3:wm-icons ########################################### [100%]

# switchdesk fvwm

# touch /usr/share/xsessions/fvwm.desktop
# vi /usr/share/xsessions/fvwm.desktop
[Desktop Entry]
Encoding=UTF-8
Name[ja]=fvmw
Comment=
Exec=fvmw
Icon=
TYpe=Application


~/.fvwm/.fvwm2rcを開いて、以下を追記します。

AddToMenu MenuFvwmQuitVerify "$[gt.Really Quit Fvwm?]" Title
+ "&Q. $[gt.Yes, Really Quit]" Quit
+ "" Nop
+ "&R. $[gt.Restart]" Restart
+ "" Nop
+ "&F. $[gt.Start] fvwm-themes" Restart fvwm-themes-start
+ "&T. $[gt.Start] twm" Restart twm

下準備はこれだけ。
Fvwmでログインしてテーマ変更。ヽ(´ー`)ノ
a0021920_1643726.gif

[PR]
by tenten909 | 2011-04-16 16:43 | PC-Unix等
「fastestmirror」の無効化

# vi /etc/yum/pluginconf.d/fastestmirror.conf


[main]
enabled=0
verbose=0
socket_timeout=3
hostfilepath=/var/cache/yum/timedhosts.txt
maxhostfileage=10
maxthreads=15
#exclude=.gov, facebook


0:無効
1:有効
[PR]
by tenten909 | 2011-04-16 16:31 | PC-Unix等
VMware上にCentOS5.6 32bit 版をセットアップ。
# yum -y install openmotif

http://mirror.centos.org/centos/5.6/os/i386/CentOS/
から
openmotif-devel-2.3.1-5.el5_5.1.i386.rpm
libXp-devel-1.0.0-8.1.el5.i386.rpm
をDownload & Install 。

openCDE
よりソースをDownload & 解凍。

$ cd opencde/src
$ gmake
$ cd ..
$ su
#cp -r bin etc share lib /usr/local

root権限で”/usr/share/xsessions/”以下に”opencde.desktop”を作成。
中身は以下のような感じ。
[Desktop Entry]
Encoding=UTF-8
Name=opencde
Comment=
Exec=opencde
Icon=
Type=Application

で、いったん logout 。

GDM のセッション選択で opencde を選択。以上です。
a0021920_19242477.gif


64bit環境ではあいかわらずダメです(>_<)

More
[PR]
by tenten909 | 2011-04-13 19:24 | PC-Unix等
Postfix でメールキューに溜まっているメールを強制的に再送信。

# postfix flush
[PR]
by tenten909 | 2011-03-13 06:53 | PC-Unix等
仕事場Windows(Cygwin) > おうちLinux(CentOS) > KVM上のWindows へ接続。
Cygwinで
$ ssh -L 6000:192.168.10.250:5900 tetsuo@hoge.moge.jp
として接続。
オプション-Lを指定。6000の部分は任意の数字(ポート指定)。IPアドレスは目的のマシンのアドレス。5900はVNCのデフォルト設定で使用されるポート番号。

UltraVNC Client で localhost:6000
でWindowsへ接続。
a0021920_16234855.jpg
ちゃんと繋がった!♪
[PR]
KVMマシン(Fedora11)にhtopコマンドをinstallしてみました。(CentOSにもいれました。)
# yum -y install htop
a0021920_1538216.gif
CPUの使用具合がグラフィカルでわかりやすいし、なにより直接killできたりするので便利だわ。

教えてくださってありがとうございます。
[PR]
by tenten909 | 2010-10-15 15:40 | PC-Unix等
memo:ネットで拾った情報。
-引用-
yum localinstall /ダウンロードしたディレクトリ/ダウンロードしたパッケージ.rpm --nogpgcheck
とすれば依存関係を解決しながら野良パッケージをインストールできます

[PR]
by tenten909 | 2010-08-21 19:17 | PC-Unix等
firestarter のインストール
Firestarterでファイアウォール設定をGUI化
A Modern Linux Firewall 本家。

まだ install が完了しただけです。

install の memo

# wget http://prdownloads.sourceforge.net/firestarter/firestarter-1.0.3-1.src.rpm?download

# rpmbuild --rebuild firestarter-1.0.3-1.src.rpm
firestarter-1.0.3-1.src.rpm をインストール中です。
警告: ユーザ majix は存在しません - root を使用します
警告: グループ majix は存在しません - root を使用します
警告: ユーザ majix は存在しません - root を使用します
警告: グループ majix は存在しません - root を使用します
エラー: ビルド依存性の失敗:
perl-XML-Parser は firestarter-1.0.3-1.x86_64 に必要とされています

# yum install perl-XML-Parser

# rpmbuild --rebuild firestarter-1.0.3-1.src.rpm

# cp /usr/src/redhat/RPMS/x86_64/firestarter-1.0.3-1.x86_64.rpm .

# ls
Desktop firestarter-1.0.3-1.src.rpm install.log
firestarter-1.0.3-1.x86_64.rpm

# rpm -ivh firestarter-1.0.3-1.x86_64.rpm
準備中... ########################################### [100%]
1:firestarter ########################################### [100%]
[PR]
by tenten909 | 2010-07-16 18:40 | PC-Unix等
5.5になりましたねえ~
といきなり言われてピンとこなかった。CentOSだったのね(汗)
a0021920_214225.jpg

コソッとリモートでつないでupdateしてみると・・・無事update完了。
[PR]
by tenten909 | 2010-05-20 20:59 | PC-Unix等