以前CPU換装後にKVMのGUESTマシンがうまく起動しなくて色々やってるうちになんとなく動いてしまったので放っておいたのですが、ちょっとトラブルがありKVMのHOSTマシンを再起動すると、やっぱり動かない。症状再現です。
BIOSをじっくり見直してみましたが、問題になりそうなところはありません。

# lsmod | grep kvm
kvm_amd 30876 0
kvm 152920 1 kvm_amd
普通に返ってきます。

/var/log/messages を眺めていると
Jun 23 07:14:08 KVMsrv avahi-daemon[1622]: Withdrawing address record for fe80::
7ca7:1fff:fe18:9938 on vnet0.
Jun 23 07:14:08 KVMsrv kernel: br0: port 2(vnet0) entering disabled state
Jun 23 07:14:08 KVMsrv kernel: device vnet0 left promiscuous mode
なにやら怪しい雰囲気です。

試しに
# /etc/rc.d/init.d/avahi-daemon stop
Avahi デーモンを停止中: [ OK ]

で仮想マシンを起動すると無事起動!!
あたりか!?
んじゃ、もう起動しないでねと
[root@KVMsrv ~]# chkconfig avahi-daemon off
[root@KVMsrv ~]# chkconfig --list avahi-daemon
avahi-daemon 0:off1:off2:off3:off4:off5:off6:off

しばらくコレで様子をみます。
[PR]
by tenten909 | 2011-06-23 07:28 | PC-Unix等
Phenom x3 8450で動いているマシンにAthlon II x4 605e を載せてみようと計画。うまくいけば消費電力の大幅ダウンです。エコエコです。興味ないけど。
a0021920_1382454.jpg

マザーボードはAMD770+SB600 Jetway PA77GTA-VT です。
購入してから一度もBIOSのUPDATEをした覚えがないので、Athlon II が対応できるようにします。
幸いCPUのサポートリストに”AMD Athlon II x4 AD600EHDK42GI Propus 512K L2 x4 C2 2.2GHz 45W”と表記されています。

BIOSのUPDATEはFDDベース。久しぶりのFD起動なので、ディスクが腐ってないか心配です。
a0021920_1353323.jpg

BIOSをUPDATEできたらCPUの交換。CPUクーラーがでかくて、少しフィンを歪めてしまいました。
a0021920_1381013.jpg

最新BIOSになったにもかかわらず、POST画面でCPUはunknownと表示。なんかちょっとくやしい。

OSはFedora 11。実はOSが起動するかどうかが1番不安でしたが、1発で起動。
カーネルのバージョンを変えて起動しても大丈夫。

ところがです。
どうやっても仮想マシンが起動途中で落ちるのです。実マシンは問題ないのに!!
仮想マシンの登録をやり直したり、BIOSの設定を見直したりしましたが事態は変わらず。
qemuをコマンドラインから起動してもダメ。

再起動を繰り返す仮想マシンを眺めてたら、なんか吹っ切れて登録してる仮想マシン全部をスタートさせて再起動のループを眺めていたら、突然1つが起動。1つ起動するとまた一つと、結局全部起動。
再起動かけても大丈夫。頭の中は?????
結局、これは原因が解らず。ログをみてもヒントになりそうなモノはないし。

納得はいかないけど、結果オーライです(>_<)
無事3coreから4coreへ、しかも消費電力ダウン。
a0021920_1523774.jpg
a0021920_1524715.jpg

[PR]
Windowsで言うところのタスクバー。
普通なら各windowごとに下のパネルに表示されるはずが、まったく表示されない。表示されないので、最小化してしまったWindowをアクティブにできない。

下のパネルを右クリック。パネルへ追加を選択。
ウィンンドウの一覧を追加。
a0021920_3521278.jpg
すると下のパネルによーく見ないと分からない仕切りのようなモノが出現。(赤丸部分)
a0021920_3532840.jpg
これが出ていればWindowの切り替えができる。

でも、なんで設定が飛んだのかは不明。
[PR]
by tenten909 | 2011-06-01 03:54 | PC-Unix等
Fedora11(KVM Machine)連続稼動234日目にて、メモリ増設のためシャットダウン、ご苦労さまです。
a0021920_2163521.gif

[PR]
by tenten909 | 2011-05-20 21:06 | PC-Unix等
インストールガイド
http://dev.maxxdesktop.com/trac/maxxdesktop/wiki/DR3_Installation_Guide

$ su -
# yum install libXp
# yum install xorg-x11-fonts-misc.noarch bitmap-fonts.noarch
# yum install xorg-x11-fonts-75dpi.noarch xorg-x11-fonts-100dpi.noarch
# yum install xorg-x11-fonts-ISO8859-1-100dpi.noarch xorg-x11-fonts-ISO8859-1-75dpi.noarch

$ wget http://maxxdesktop.com/downloads/DR3/MaXX-DR3-Installer.sh
$ chmod a+x MaXX-DR3-Installer.sh
$ su
# ./MaXX-DR3-Installer.sh

以上です。
いったんログアウトして、GDMでsessionをMaXXに変更してログイン。


当然というか、日本語関係がヤバイです。
それにしても公式ページに大きな進展が無いのが不安です。
a0021920_1353096.jpg

[PR]
by tenten909 | 2011-05-05 01:35 | PC-Unix等
# yum install tigervnc-server

$ vncpasswd
Password:
Verify:

# vi /etc/sysconfig/vncservers
VNCSERVERS="7:tetsuo"
VNCSERVERARGS[7]="-geometry 1024x768 -depth 24"
sampleでは7ではなく2だったのですが、2だと起動に失敗したので7にしました。
もちろん警告がでるのですが…
# /etc/rc.d/init.d/vncserver start
VNC サーバー を起動中: 7:tetsuo xauth: (stdin):1: bad display name "KVMsrv.tenten909.jp:7" in "add" command


使えてるので、考えるのは後にします。
追記:/etc/resolv.conf内で内向きのDNSサーバーを指定すればxauth: (stdin):1: bad display nameは出なくなりました。初歩的な事だったのですね(涙)
DNSがたってない場合は /etc/hosts の設定をすればOKなのかな・・・


# chkconfig vncserver on
a0021920_338855.jpg

[PR]
by tenten909 | 2011-04-18 03:38 | PC-Unix等
KVMマシン(Fedora11)にhtopコマンドをinstallしてみました。(CentOSにもいれました。)
# yum -y install htop
a0021920_1538216.gif
CPUの使用具合がグラフィカルでわかりやすいし、なにより直接killできたりするので便利だわ。

教えてくださってありがとうございます。
[PR]
by tenten909 | 2010-10-15 15:40 | PC-Unix等
memo:ネットで拾った情報。
-引用-
yum localinstall /ダウンロードしたディレクトリ/ダウンロードしたパッケージ.rpm --nogpgcheck
とすれば依存関係を解決しながら野良パッケージをインストールできます

[PR]
by tenten909 | 2010-08-21 19:17 | PC-Unix等
Fedora13 クリーンインストール状態を3度試しましたがダメでした。
結局Fedora11を入れ直し、勝手に書き換わった定義ファイルと自分で書き換えた定義ファイルを修正し、なんとか以前の状態へ。

いったんFedora13のKVMで起動を試したVMイメージは、定義ファイルのXMLが書き換わってしまって、Fedora11では正常に起動できなかった。

まさか同じDistributionで互換性が無いような状態になるとは思ってもみませんでした。(>_<)
[PR]
by tenten909 | 2010-07-28 01:46 | PC-Unix等
念の為BIOSのチェックもしたけど大丈夫。virtualizationはenableでした。

kernel は
kernel-2.6.33.6-147.fc13.x86_64です。

# lsmod | grep kvm
kvm_amd 33194 0
kvm 253098 1 kvm_amd


# ls /dev/kvm
/dev/kvm


KVMが使える環境のはずなんですが。

# qemu-kvm -monitor stdio
kvm_create_vm: Device or resource busy
Could not initialize KVM, will disable KVM support
QEMU 0.12.3 monitor - type 'help' for more information

(qemu) info kvm
kvm support: disabled


disabled。なぞすぎます。(T_T)
[PR]
by tenten909 | 2010-07-26 11:37 | PC-Unix等